Skip to end of metadata
Go to start of metadata

Apple released its latest operating system (macOS 10.13 - High Sierra) for Apple computers this past September.  ITS has reviewed this operating system per our policy and is providing the following information to help you decide if you should upgrade.

Note:  ITS has determined that this is not a critical update and upgrading is not necessary nor required.

If considering upgrading, please review the following to ensure you will be able to use your current applications:


Application

Supported

Notes

Office 2011

Not Supported

Will work

Office 2016

Supported

Must be upgraded *Prior* - or Word breaks

SPSS (v.24)

Not Supported

*Do Not Upgrade*

Adobe CS6

Not Supported

Upgrade will mostly work but ITS cannot assist*

Adobe CC/DC

Supported

 

Adobe Pro XI

Not Supported

Will work

Filemaker 11

Not Supported

*Do Not Upgrade*

Other Applications

Check with Manufacturer

 


Once you have reviewed the above you may update to High Sierra if you wish to. 

*CS6 can be used and installed at your own discretion (instructions: https://helpx.adobe.com/creative-cloud/kb/install-creative-suite-mac-os-sierra.html). Once installed you will need to manually update the apps to the latest version (see: http://www.adobe.com/downloads/updates.html)

For further assistance, please visit the ITS4U Help Desk located in NYS 215 or call 203-254-4069 during business hours.

Hours can be found here: ITS4U Help Desk Hours of Operation

  • No labels